Incident 7696: Device HOS Widget Degradation

Incident Report for Platform Science Mobility

Resolved

This incident is resolved. The app update will continue to deploy automatically to devices on older versions as they come online. Drivers may also update manually through the Google Play Store to receive the fix immediately.
Posted Jul 29, 2026 - 17:16 CDT

Monitoring

A fix has been implemented and is being deployed automatically to all devices. Drivers whose hours are not yet displayed in the Hours of Service widget may restore functionality immediately by manually updating the app through the Google Play Store.

We will continue to monitor the deployment closely until full recovery is confirmed.
Posted Jul 29, 2026 - 15:52 CDT

Update

Following our initial investigation, our engineering teams have begun implementing corrective measures for the issue affecting the Hours of Service widget. Impacted drivers may not see their hours/clocks on this screen until remediation is complete.

We will provide further updates as more information is confirmed.
Posted Jul 29, 2026 - 15:16 CDT

Identified

We are investigating an issue affecting the Hours of Service widget for some drivers. We will provide further updates as more information becomes available.
Posted Jul 29, 2026 - 14:41 CDT
This incident affected: ELD (Driver Logs).